Apa Itu Load Balancing Mikrotik?

Load Balancing Mikrotik – Dalam sebuah jaringan komputer yang padat, tentunya yang namanya pengiriman data dan penerimaan data akan selalu ada dan akan selalu bekerja secara bersamaan. Tentunya hal ini akan membuat lalu lintas jaringan akan menjadi ruwet. Maka dari itu, ada yang namanya hardware bernama load balancing.

Ibaratkan saja jika lalu lintas jaringan internet yang ada di kantor Anda atau instansi Anda mengalami gangguan hanya karena paket data yang bertabrakan, tentu sangat menyusahkan. Maka dari itu, perlu adanya load balancing dari Mikrotik.

Pengertian Load Balancing Mikrotik

Load balancing adalah proses mendistribusikan lalu lintas jaringan di beberapa server. Ini memastikan tidak ada satu server pun yang menanggung terlalu banyak permintaan. Dengan menyebarkan pekerjaan secara merata, load balancing meningkatkan respons aplikasi. Ini juga meningkatkan ketersediaan aplikasi dan situs web untuk pengguna.

Load balancer mengelola aliran informasi antara server dan perangkat titik akhir (PC, laptop, tablet, atau ponsel cerdas). Server bisa di tempat, di pusat data atau cloud publik. Server juga dapat berupa fisik atau virtual. Penyeimbang beban membantu server memindahkan data secara efisien, mengoptimalkan penggunaan sumber daya pengiriman aplikasi, dan mencegah kelebihan beban server. 

Load balancing Mikrotik melakukan pemeriksaan kesehatan berkelanjutan pada server untuk memastikan mereka dapat menangani permintaan. Jika perlu, load balancing Mikrotik menghapus server yang tidak sehat dari kumpulan hingga dipulihkan. Beberapa penyeimbang beban bahkan memicu pembuatan server aplikasi virtual baru untuk mengatasi peningkatan permintaan.

Load Balancing Mikrotik Paling Bagus

Berbicara tentang load balancing Mikrotik, terdapat beberapa load balancing Mikrotik yang paling bagus yang bisa diterapkan sesuai dengan kebutuhan.

Load Balancing Mikrotik 2 ISP

Pada mikrotik, terdapat banyak metode yang bisa digunakan jika Anda memiliki lebih dari 2 jalur internet seperti BGP, Failover, Load Balance, dll. Load balancing Mikrotik 2 ISP merupakan salah satu yang paling bisa diandalkan.

Load Balancing Mikrotik PCC

Metode yang bernama Load Balancing Mikrotik PCC adalah jika Anda menggunakan load balancing dua jalur koneksi.

PCC (Per Connection Classifier). Dengan PCC kita bisa mengelompokan trafik koneksi yang via atau keluar masuk router menjadi sebagian kelompok. Pengelompokan ini bisa dibedakan berdasarkan src-address, dst-address, src-port dan atau dst-port. Router akan mengingat-ingat jalur gateway yang dilalui diawal trafik koneksi, sehingga pada paket-paket berikutnya yang masih berhubungan dengan koneksi mulanya akan dilewatkan pada jalur gateway yang sama juga.

Load Balancing Mikrotik 3 ISP

Ini adalah salah satu load balancing Mikrotik yang sangat menguntungkan. Jadi, load balancing Mikrotik 3 ISP merupakan hal yang dinamakan failover. 

Jika Anda menjalankan load balancing sekaligus ke 3 ISP tersebut maka performa jaringan kita akan menjadi tidak optimal sebab ada 1 ISP memiliki shared bandwidth. Walaupun angkanya lebih besar ketimbang yang dedicated, namun shared artinya 100Mbps itu masih dibagi-bagi lagi, biasanya bandwidth rata-rata yang kita temukan hanya sekitar 15-20Mbps.

 

Oleh sebab itu, kita hanya akan menjalankan load balancing memakai 2 ISP yang memiliki dedicated bandwidth. Sementara ISP yang memiliki shared bandwidth akan dihasilkan sebagai backup dikala segala ISP dedicated bandwidth mengalami problem (down).

Load Balancing Mikrotik NTH

Di load balancing Mikrotik terdapat fitur yang bernama NTH. NTH sendiri ialah sebuah fitur pada firewall Mikrotik yang dipakai sebagai penghitung (counter) dari paket data atau koneksi (packet new). Ada dua parameter utama dari NTH ini, merupakan “Every” dan “Packet”.

“Every” adalah parameter penghitung (counter) meskipun “Packet” ialah penunjuk paket keberapa rule dari NTH ini akan dikerjakan. Dengan demikian penerapan NTH ini dilaksanakan denganmengaktifkan counter pada mangle, kemudian ditandai dengan ‘Route-Mark’. Sehingga dengan route mark ini dipakai sebagai dasar untuk membikin policy route.

Setting Load Balancing dan Failover Mikrotik

Sudah disinggung tadi diatas jika terdapat bagaimana cara untuk setting load balancing dan Failover Mikrotik, ini sangat berguna jika Anda ingin menggunakan 3 ISP secara langsung.

Sebelum mengawali konfigurasi, supaya memudahkan membuat rule mangle, buatlah address list yang isinya alamat network LAN dan network yang segera terkoneksi ke router. Cara untuk topologi di atas, ada ether1-ISP1, ether2-ISP2, ether3-ISP3, dan jaringan LAN (hanya 1), maka:

/ip firewall address-list

add address=11.11.11.0/24 list=LAN

add address=22.22.22.0/24 list=LAN

add address=33.33.33.0/24 list=LAN

add address=192.168.100.0/24 list=LAN

Paket hal yang tadi dapat digolongankan menurut src-address, src-port, dst-address, dan dst-port.

  1. Firewall Mangle

/ip firewall mangle

add action=mark-routing chain=prerouting src-address-list=LAN dst-address-list=!LAN \

    dst-address-type=!local new-routing-mark=route_to_ISP1 passthrough=no \

    per-connection-classifier=both-addresses:2/0

add action=mark-routing chain=prerouting src-address-list=LAN dst-address-list=!LAN \

    dst-address-type=!local new-routing-mark=route_to_ISP2 passthrough=no \

    per-connection-classifier=both-addresses:2/1

Karena kita menggunakan src-address dan dst-address saja (both-address), maka setiap mark dinamai  route_to_ISP1 dan route_to_ISP2.

Berikutnya kita buat recursive route menerapkan protocol static route untuk me-route traffic ke dunia online. Kita catat dulu gateway masing-masing ISP.

ISP1: 11.11.11.1

ISP2: 22.22.22.1

ISP3: 33.33.33.1

Karena ada 3 ISP yang akan kita pakai untuk recursive route ke dunia online, karenanya kita memerlukan 3 IP publik yang ada di dunia online untuk diwujudkan recursive default gateway. Pastikan IP ini bisa di-ping dan jarang down.

ISP1: 11.11.11.1 ==> 1.0.0.1

ISP2: 22.22.22.1 ==> 1.1.1.1

ISP3: 33.33.33.1 ==> 8.8.4.4

/ip route

 

## Static host route ke public ip yang ada di internet.

## Atur nilai scope yang baru (bedakan dari default scope=30), contoh=25.

add distance=1 dst-address=1.0.0.1/32 gateway=11.11.11.1 scope=25

add distance=1 dst-address=1.1.1.1/32 gateway=22.22.22.1 scope=25

add distance=1 dst-address=8.8.4.4/32 gateway=33.33.33.1 scope=25

 

## Default gateway untuk me-route traffic yang berasal dari router itu sendiri.

## Nilai target-scope samakan dengan nilai scope pada static host route.

## Parameter check-gateway=ping membuat router melakukan ping ke gateway setiap interval 10 detik,

## Jika ping 2x timeout secara berturut turut,

## maka link ke ISP yang recursive ke gateway tersebut dianggap down.

add check-gateway=ping distance=1 gateway=1.0.0.1 target-scope=25

add check-gateway=ping distance=2 gateway=1.1.1.1 target-scope=25

add check-gateway=ping distance=3 gateway=8.8.4.4 target-scope=25

 

## Default gateway untuk me-route traffic yang diberi mark route_to_ISP1.

## Nilai target-scope samakan dengan nilai scope pada static host route.

## Atur prioritas menggunakan distance: ISP1, ISP2, ISP3

add distance=1 gateway=1.0.0.1 routing-mark=route_to_ISP1 target-scope=25

add distance=2 gateway=1.1.1.1 routing-mark=route_to_ISP1 target-scope=25

add distance=3 gateway=8.8.4.4 routing-mark=route_to_ISP1 target-scope=25

 

## Default gateway untuk me-route traffic yang diberi mark route_to_ISP2.

## Nilai target-scope samakan dengan nilai scope pada static host route.

## Atur prioritas menggunakan distance: ISP2, ISP1, ISP3

add distance=1 gateway=1.1.1.1 routing-mark=route_to_ISP2 target-scope=25

add distance=2 gateway=1.0.0.1 routing-mark=route_to_ISP2 target-scope=25

add distance=3 gateway=8.8.4.4 routing-mark=route_to_ISP2 target-scope=25

Jasa Setting Load Balancing

Mungkin masih ada banyak orang yang tidak paham dengan cara penggunaan load balancing. Walaupun memang ini adalah salah satu hal yang diperlukan, tentunya mau bagaimanapun load balancing harus ada pada setiap jaringan komputer yang padat seperti instansi perkantoran, pemerintahan, sekolah, universitas, sudah harus menggunakan load balancing.

Jika Anda masih tidak bisa untuk melakukan setting load balancing, maka Anda bisa menyewa jasa setting load balancing. Jasa seperti ini memang sudah sangat umum Anda temukan jika Anda ingin memasang load balancing.

NetData sangat bisa Anda andalkan untuk jasa setting load balancing, Anda akan mendapatkan jaminan load balancing yang stabil dan juga dengan biaya jasa yang terjangkau dengan kualitas terbaik.

Kesimpulan

Tujuan utama dari load balancing adalah untuk mencegah satu server dari kelebihan beban dan kemungkinan mogok. Dengan kata lain, load balancing mampu meningkatkan ketersediaan layanan dan membantu mencegah downtime.

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

Semua operasional PT. Network Data Sistem akan menggunakan domain nds.id per tanggal 8 Mei 2019. Semua informasi/promosi dalam bentuk apapun selain menggunakan domain nds.id bukan tanggung jawab PT. Network Data Sistem Tutup